Browser Requirement Update 2018

Published on Mar 13, 2018

It is important to stay up-to-date on the most recent technology in order to ensure your financial transactions are secure. We are implementing an update on April 9, 2018 that will affect website security used to encrypt & protect information.

The most recent upgrade provided is only compatible with TLS version 1.2. If your devices(computers, tablets and phones) are more recent and the browsers (Internet Explorer, Chrome) have been updated, you should not experience any delay in your services. If your device or operating system is not compatible, you will be unable to access Mobile or Online Banking as of April 9th.

If you have devices or browsers that have not been updated, please review the content below for required specifications. Find helpful tutorials on our website and listed below.

If you need further assistance, please call us at 894-1000 or send us an email at

Currently supported browsers that use TLS version 1.2 are:

  • Apple Safari 7.0 or above
  • Google Chrome
  • Microsoft Edge
  • Microsoft Internet Explorer 11.0 or above
  • Mozilla Firefox

Business Banking From Anywhere

GVB Business
Mobile App

Available Now!


Back to Top